Языки программирования с русским синтаксисом

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Языки программирования с русским синтаксисом » Другие ЯП с русскими операторами . » 1Script - OneScript - 1С язык для написания скриптов на Windows/Linux


1Script - OneScript - 1С язык для написания скриптов на Windows/Linux

Сообщений 1 страница 2 из 2

1

Очень профессионально сделан, открытый исходный код, позволяет использовать в качестве  среды разработки (IDE) Notepad++ и / или Visual Studio Code Editor - всё с подсветкой синтаксиса и автопополнением и справкой по языку.
* https://infostart.ru/public/687869/ - Быстрый страт OneScript
* https://vk.com/1script - ВК группа по OneScript
* http://oscript.io -  Официальный сайт

0

2

Пример кода на 1скрипт
Процедура ОбработатьКаталог(Знач Каталог)
Сообщить("Обрабатываю каталог " + Каталог);
КаталогГит = Новый Файл(Каталог + "\.git");
Если Не КаталогГит.Существует() Тогда
    Сообщить("Каталог не является git-репозиторием");
    Возврат;
КонецЕсли;
ЛогГит = ПолучитьИмяВременногоФайла();
КодВозврата = -1;
ЗапуститьПриложение("cmd /C git remote -v > " + ЛогГит, Каталог, Истина, КодВозврата);
Если КодВозврата <> 0 Тогда
    Сообщить("Ошибка получения git remote");
    Сообщить(ПрочитатьФайл(ЛогГит));
    Возврат;
КонецЕсли;
ОсновнойАдрес = ПрочитатьАдрес(ЛогГит);
Если ОсновнойАдрес = Неопределено Тогда
    Возврат;
КонецЕсли;
Сообщить("URL: " + ОсновнойАдрес);
НовыйУрл = СтрЗаменить(ОсновнойАдрес, "http://old-server", "http:new-server");
Сообщить("Перенаправляю на " + НовыйУрл);
КодВозврата = -1;
ЗапуститьПриложение("cmd /C git remote set-url origin " + НовыйУрл + " > " + ЛогГит, Каталог, Истина, КодВозврата);
Если КодВозврата <> 0 Тогда
    Сообщить("Ошибка git set-url");
    Сообщить(ПрочитатьФайл(ЛогГит));
    Возврат;
КонецЕсли;
Сообщить("Каталог " + Каталог + " обработан");
КонецПроцедуры

0


Вы здесь » Языки программирования с русским синтаксисом » Другие ЯП с русскими операторами . » 1Script - OneScript - 1С язык для написания скриптов на Windows/Linux


форум на 24bb Создать форум бесплатно